1. Please take 30 seconds to register your free account to post, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

EBS Users: help needed

Discussion in 'Amps and Cabs [BG]' started by Lenko, Dec 23, 2004.


  1. Lenko

    Lenko

    May 3, 2003
    Slovenia
    Hi there;
    I'm a happy HD350 user, but I've been having a "problem" lately (I put the word problem in "" because I don't know if it is a problem really). The sound changes very little if I turn the bright knob on; the difference in sound between the knob full on and turned off is barely noticeable. I was wondering if any of you guys could put up a soundclip with the bass and the amp set both flat with no compressor or drive and another one turning the bright knob all the way up, playing a very simple bass line and some harmonics, so I could compare it to the sound I'm getting out of my amp.

    Thanks
     
  2. inazone

    inazone Supporting Member

    Apr 20, 2003
    Colorado
    Basses react different with different heads and cabs. I had a ebs td650 and with one bass it was the same as what you say. Plug a different bass in and the knob worked a lot more.

    Try a different bass through your head, see what that does.
     
  3. 8_finger

    8_finger

    Jun 1, 2002
    Baltimore, MD
    Try boosting treble on your bass (if you have it) - that seems to help with my axe.
    Have you tried HD350 with another cab - maybe the tweeter is malfunctioining