Dismiss Notice

Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

Eden head power-off "pop"

Discussion in 'Amps and Cabs [BG]' started by Bass Invader, Feb 25, 2004.


  1. Bass Invader

    Bass Invader

    Mar 10, 2003
    Osaka Japan
    Just a quick question to any other Eden owners!

    I've just purchased a WT550 (sweet piece of kit) and I've noticed a very loud "POP" which occurs when I power it off. Is this normal? Should I be concerned?

    Thanks for any help anyone can give!
     
  2. I'm not an Eden owner but is your master volume cranked down when you turn it on(or off)?I know it might be a stupid question but usually "pops" when the volume isn't down.
     
  3. baba

    baba Supporting Member

    Jan 22, 2002
    3rd stone from the sun
    Exactly. Turn down your master.
     
  4. metron

    metron Fluffy does not agree

    Sep 12, 2003
    Lakewood Colorado
    I dont have any experience with Eden but my power amp does the same thing with all volume controls turned down. The only way I have found to avoid it is to unplug the speaker cable before turning the amp off. Lots of amps have turn off transients.
     
  5. My Ampeg SVT-III Pro did the same thing but only when I turned it on. And yes I did have gain and master turned off. I would turn it on and wait a few seconds and then POP!
     
  6. Gard

    Gard Commercial User

    Mar 31, 2000
    Greensboro, NC, USA
    General Manager, Roscoe Guitars
    Hmm...my WT550 doesn't do that, nor does my WT-1000 power amp...however, SWR amps are notorious for doing that POP when you turn 'em off...

    ...I wouldn't worry about it too much, try turning the master volume down to see if that helps.
     
  7. If the head has a mute switch, leave it engaged when turning on or off.It should cut the signal to the speakers. I don't know if it's good for the head,though.
     
  8. Tried all of those things on the svt III-pro and didn't work, so I wouldn't be surprised if it doesn't work for the Eden.
     
  9. Bass Invader

    Bass Invader

    Mar 10, 2003
    Osaka Japan
    Jeez I feel pretty dumb now.. yeah, it seems to be OK with the master volume down on power-off. Don't know why that didn't occur to me earlier. Must be the AWESOME TONE.. distracting me from logical thought..

    Thanks for all the help.
     
  10. zoran

    zoran

    May 10, 2002
    croatia
    Mine setup too, but I had few pops and ended with blown speakers :meh:
     
  11. When i was at Bass Central this past january i was hooked into a WT 550 with a $6200 fodera i was "checking out" and as soon as i hit the power there was a wicked loud POP and Beaver felton just yelled from his desk "Gard! Whats going on!!"...i think they were a little freaked out i might have broken something and i was so afraid that i blew something while holding some of the most expensive gear they had...i almost soiled myself in fear of having to max out the credit card to buy all the gear i thought broke.
     
  12. In a few words, you missed your chance to get a $6200 Fodera + Eden Stack.;) :D