Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

Eden Metro Reliability

Discussion in 'Amps and Cabs [BG]' started by addy, May 22, 2004.


  1. addy

    addy

    May 18, 2004
    I am planning to purchase an Eden Metro used, as I am getting a decent deal on it....

    I'm wondering if any owners can let me know on the reliability issues associated with the amplifier...

    thanks.
     
  2. Here is my $00.02 worth. My Metro is dated 1999 and came to me from Beaver at Bass Central in Florida. It worked great for about one month and then I powered it up to play a little at home and, HISSSSSSSSSS, POP!
    I pulled the head and sent it to Eden (made more sense than sending the whole 78# unit) and they gave it the once over a couple of times and sent it back. It arrived with a few mods and upgrades and has worked just fine ever since. It seems that UPS beat it kind of hard during shipping which caused a few solder points to seperate.
    The boys at Eden told me this but repaired at no cost to me.
    Pretty cool.
    This isn't to say that your rig will be perfect, but sending it in for a look by Eden's techs might be a good idea.
    Harmony Central and BGRA each have quite a few reviews.
    Good luck, the rig works well for me.
     
  3. Brendan

    Brendan

    Jun 18, 2000
    Austin, TX
    They are some of the most reliable amps I've even heard of.

    Feel safe.
     
  4. neptoon

    neptoon

    Jul 25, 2000
    summerville, sc
    i used mine for about 6 years with no problem other than blown drivers---which was my fault...GREAT amp...sounds good, too...