eden wt 500 noise

Discussion in 'Amps and Cabs [BG]' started by mindflow, Oct 24, 2005.

  1. mindflow


    Oct 31, 2004
    San Diego
    i just bought a wt500 on the bbay and it is freaking noisy from thhe moment i turn it on. i A/Bed it next to my GK 400RB and the hiss that it makes when its just sitting there is about twice as loud. also whats weird is the eden is rated at 600 watts bridged and the gk is rated at about half that (cant remember) but the Gk is way louder when im playing my bass compared to the eden. with the eden the only way i can get significant volume is when the gain is turned up, otherwise im running the eden with the volume turned to the maximum level. any thoughts before i take it in and get taken by the seat of my pants? i have a recording coming up and the eden hiss is too loud to be recording with. also, the eden was made in 1976 if that makes any difference.
  2. While there are many comments on this site about the Eden's being quite noisy, something sounds wrong here. You might want to check the preamp tube... that could be the problem with the large amount of hiss and the seemingly low output level.
  3. I also have a WT-500, from 1994, which produces a fair amount of hiss at idle. The hiss seems to be at least partially due to the design. However, I would not say that mine is lacking in output volume.

    Generally, with an Eden WT amp, starting with all of the EQs flat, and the Enhance off all of the way, you want to raise the input gain until the Set Level LED flashes (compressor off), then adjust the Master for overall volume.

    In bridge mode, only the left channel works, and some have reported better performance by panning the balance all the way to the left.

    If you try the recommended method above and still have problems, there may be something wrong with your amp.

    By the way, the first WT-500s would be from around 1993. Eden discontinued the model around 2003.
  4. mindflow


    Oct 31, 2004
    San Diego
    i must be wrong about the date. i thought i read thatvhand written on the back though. this is the highwayman. ill check out your suggestions. thanks very much for the help. when you say the eq flat do you mean just straight up (vertical?)
  5. By design, flat EQ on the Eden is 12:00 noon, or straight up, except Enhance, which is flat when all the way to the left. 12:00 on the Enhance gives a serious mid scoop.

    However, to my ears, Eden's flat setting is a bit dull sounding, and the WT-500 sounds "more flat" when the EQ is set flat, but the Enhance is around 8:00.

    Check out this guide on the Eden site: