1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

Eden WTX 500 questions from a noob

Discussion in 'Amps and Cabs [BG]' started by Gonnabeahustla, Mar 18, 2013.


  1. Gonnabeahustla

    Gonnabeahustla

    Nov 13, 2011
    Hello all! I have recently purchased an eden WTX 500 and am having some issues with it. I have been using it with an ampeq 4X10- 400 w 4 ohm cab.

    I cant seem to raise the gain past 2-3 without constantly clipping/setting off the limit and set level lights on the amp...I end up having to crank the master volume, even with the bass/mid/high knobs set to 0.

    Help me talkbass...you're my only hope
     
  2. Arod1213

    Arod1213

    Feb 24, 2013
    Do you use any pedals when you play if so that may be the reason
    Also if your bass is active turn the preamp off and you could substitute a preamp pedal
     
  3. nonogz

    nonogz

    May 9, 2009
    The gain isn't suppose to be cranked that high. Turn your amps master volume and gain all the way down. Turn your bass' volume all the way up. Start playing and turn the gain up gradually. When it starts clipping, take it back a couple clicks. Your gain is set. Now control your volume with the master volume knob
     
  4. Gonnabeahustla

    Gonnabeahustla

    Nov 13, 2011
    Iplay an ibanez sr700

    I use a zoom b3 pedal but got it after the eden head, and had the same issues
     
  5. Gonnabeahustla

    Gonnabeahustla

    Nov 13, 2011

    I will def give this a shot. I used to have an SWR workingman head and always had the gain set really high and got a great punchy tone from it
     
  6. nonogz

    nonogz

    May 9, 2009
    Check out the eden manual too...useful info. I just put a wr800 on layaway after falling in love at guitar center!
     

Share This Page