Electro Harmonix Black Finger problems...

Discussion in 'Effects [BG]' started by Count Jodius, Jul 28, 2005.

  1. Count Jodius

    Count Jodius

    Jul 28, 2005
    Hey, hows everyone doing? I'm new to the site!

    I've got a small problem with a EH Black Finger that I purchased from ebay yesterday. Firstly, there doesn't seem to be a great deal of a change in sound/compression when activated, only change in level and when the pre-gain is cranked up, a subtle overdrive. I decided to hook it up to my computer to see what it sounded like recorded, and it appears that there is only a level present on the left channel!

    Does anyone have any idea why it might be doing this? I tried opening it up, and everything looks fine inside. Could it be that the valves need replacing?

    Any feedback greatly appreciated!
  2. James Hart

    James Hart

    Feb 1, 2002
    Endorsing Artist: see profile
    plugging a mono effect into a stereo jack will get you a left channel only recording
  3. atoni


    Jan 23, 2004
    Helsinki, Finland
    Endorsing Artist: Salo Guitars
  4. Count Jodius

    Count Jodius

    Jul 28, 2005
    Thanks for the replies guys. See I thought that might be the case when plugging it into a computer, however when I plug my Big Muff Pi in, I get a nice equal level in both channels, and thats a "mono" effect too!

    Thanks for the links atoni- I had a look at the Guitar Buyer link before I bought the pedal, haven't checked out the bass player one before though! Have you tried plugging yours into a computer/mixer before? Do you get this one channel thing going on with yours?