1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

EMG BTC wiring help

Discussion in 'Pickups & Electronics [BG]' started by BIGEJ2, Oct 25, 2013.


  1. BIGEJ2

    BIGEJ2 Supporting Member

    Jul 29, 2009
    Happy Valley, PA
    So I purchased a solderless EMG MMCS and BTC preamp thinking the install would be quick and easy. I'm not sure if there is an issue with the pup, preamp or wiring. When all snapped together and plugged in, I get nothing. What's interesting is that when testing volume only and disconnect the battery cable, my tuner works but there is no volume when plugged into an amp.

    I attached a pic of the wiring. Here's a link to EMG's website. Does anyone see anything wrong with my wiring? I checked and double checked the jack - I'm certain it is correct. Thanks!

    ImageUploadedByTalkBass1382734008.932673. ImageUploadedByTalkBass1382734030.350237.
     
  2. lifer_

    lifer_

    Oct 19, 2011
    Bulgaria
    I don't see something wrong on the pictures. Check the pickup connector, check the connections with that tape, the battery ones. What about your battery, is it new? Is there any chance to miss something outside the cavity, I mean like cables with mute switch, etc.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.