1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

EMG's PJ set + Aguiliar OBP 1

Discussion in 'Pickups & Electronics [BG]' started by subisina, Feb 22, 2008.


  1. subisina

    subisina

    Feb 6, 2007
    Croatia
    Hey guys,
    I own 1990 Warwick Streamer Stage 1 with EMG's PJ pick ups and Aguiliar OBP 1 electronics. I have this buzz I can't get rid of. I really tried everything from resoldering to shielding, grounding, changing the amps I plug it in... I mean everything. I tried other basses in the same conditions when the buzz appears (light switch dimmers- when set to on and off position no problem but when the light is dimmed the buzz appears, TV on...) and they were all dead silent (Musicman Stingray, some Aries model, Yamaha TRB...). I thought then the problem lies in electronics or pick ups (maybe they are too old or 'overused' if it is possible) but I was very unpleasently surprised when I came upon other Warwick bass (Corvette Proline with Mec's electronics and pick ups) and the buzz appeared again (is it possible that I came upon two Warwick basses with the same problem accidently?). Is this something about Warwicks or about pick ups or electronics, I really can't figure it out and I really like the sound of my bass. I would like to replace the Emg's with the new EMG's PJ set and EMG's BQCsystem instead of Aguiliar OBP 1 or maybe just one of these that is not functioning right but what should I do to find where the problem lies. Is it possible that these pretty apreciated instruments have such a fault - I didn't hear anybody complaining about this at Warwick forum.:help:
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.