EQD Avalanche Run mA question

Discussion in 'Effects [BG]' started by vivaknoxvegas, Apr 16, 2018.


Tags:
  1. vivaknoxvegas

    vivaknoxvegas El Duderino Gold Supporting Member

    May 6, 2002
    Knoxville, TN
    Eqd recommends 425mA operation, but is anyone running it at 400? I got a new psu that has some 400 slots available. Just wondering if it would be safe at that.
     
  2. 2010P

    2010P Inactive

    May 13, 2017
    I would imagine it would be safe but it might not work right. Had a mA issue recently with a pedal where I was running it too low. It needed 125 mA and I supplied it only 100. Same ratio as yours sort of. the pedal did not work right at all, especially at startup. But someone more knowledgable than me will probably have a more specific answer.
     
    vivaknoxvegas likes this.
  3. vivaknoxvegas

    vivaknoxvegas El Duderino Gold Supporting Member

    May 6, 2002
    Knoxville, TN
    I definitely don’t want to damage it.
     
  4. jwr

    jwr

    Jun 28, 2010
    Overland Park, KS
    It’s totally fine to under power an effect pedal like that. As long as you’re using 9v, you’re fine.
     
    vivaknoxvegas likes this.
  5. jwr

    jwr

    Jun 28, 2010
    Overland Park, KS
    I ran my Avalanche Run on like 200 ma. No issues.
     
    vivaknoxvegas likes this.
  6. Primary

    Primary TB Assistant

    Here are some related products that TB members are talking about. Clicking on a product will take you to TB’s partner, Primary, where you can find links to TB discussions about these products.

     
    Jun 15, 2021

Share This Page