1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

FBass preamp crapping out

Discussion in 'Pickups & Electronics [BG]' started by Ostinato, Oct 22, 2006.


  1. Ostinato

    Ostinato Guest

    Feb 7, 2005
    Toronto ON
    Hi guys,

    This hust happened one morning out of the blue. I'm having a bit of trouble with the onboard in my FBass and was wondering if it might be a quick fix. It seems the pull/push bridge volume does not work in humbucker mode (knob "out" position). It works fine in single coil.
    I tried moving some wires around, hoping it was a short between a wire and the circuit board and even put some foam between the wires and the board but nah...that wasn't it. Any suggestions before I take it in?
     
  2. maybe the push-pull switch itself is broken. You may fix it easily by replacing it, if the knob is not hardwired to the preamp board. Or take it back if it is under warranty
     
  3. Ostinato

    Ostinato Guest

    Feb 7, 2005
    Toronto ON
    The pots are separate. And this particular one is quite big and deep. Mechanically it seems fine, I guess I'll have to take it in to George....
     
  4. J.Wolf

    J.Wolf Supporting Member

    Apr 29, 2003
    Asheville, NC
    Contributor- Bass Musician Magazine
    Give George F a call. He's able to troubleshoot alot of things over the phone..
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.