Dismiss Notice

Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

Fender Bassman 200 clipping

Discussion in 'Amps and Cabs [BG]' started by Heavy_E, Nov 9, 2003.


  1. Heavy_E

    Heavy_E

    Jul 2, 2002
    Alabama
    I am using a Bassman 200... The problem is I am clipping at bery low volumes. I play in a praise and worship band. I keep my volume on 2 and my gain is on 5. Anytime I ride E or anything on the B string it clips. I read on the forum about being underpowered... All the EQ'ing is done from my Lakland 55-02 (active) The Bass setting is set to "half". If I play at a larger venue I am screwed if I cannot get it get the volume over "2".

    Any suggestions... I will keep searching the forums as well...

    Thanks
     
  2. CamMcIntyre

    CamMcIntyre

    Jun 6, 2000
    USA
    I've got a bassman 200. Have you tried hitting the active switch and turning up the master volume? Whenever i clip significantly I adjust the gain down a bit [to the point where the clip light doesn't come on yet the signal light still does] and boost the master volume. Do you run the preamp with any compression? I keep mine at half, the limiter would be a good thing to have on if it's a poweramp clip. I'll help out all i can but my knowledge isn't quite the extensive of some others. That's all
     
  3. Heavy_E

    Heavy_E

    Jul 2, 2002
    Alabama
    Thanks...

    I tried cutting the gain down and upping the master volume. That seemed to help. One thing I noticed is that my Lakland pickups are real "hot". So I also tried backing off the "bass" eq on the lakland. That also seemed to help. I am running the compressor between 1 and 2.