1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Flanger "swirl" in clean signal

Discussion in 'Effects [BG]' started by johnm0187, Jan 5, 2007.


  1. I have the Behringer Ultra Flanger, and it sounds great when it is activated. But when it is not, you can hear the "swirl" (I don't know what to call it). It is not very prominent, but definently noticable to me.

    Do you think this could be a loose connection in the pedal or what do you think could be causing the problem. I play a Spector Q5 through a BBE Bmax with a QSC1450 power amp and an Avatar 2x12.
    Thanks
     
  2. opivy3056

    opivy3056 stardust in a light beam

    Oct 14, 2004
    San Diego
    Its because the pedal doesnt have a good bypass. This use to happen to me with my boss delay, if i left the feedback up too high (for self-oscillation) it would still oscillate even if the pedal was off.

    It has to do with the fact that its not a true bypass circuit. I think the only way to eliminate it is to put the flanger in a loop or maybe get one of those "noise eliminator" pedals.

    With behringer, most of the time you get what you pay for.
     
  3. bongomania

    bongomania Gold Supporting Member Commercial User

    Oct 17, 2005
    PDX, OR
    owner, OVNIFX and OVNILabs
    Yep. It's not just a question of true bypass (or not) though, it can also result from poor design and poor separation of the electrical ground of the circuit from the audio path.
     
  4. Would that be easy to check/fix? I have basic knowledge of sodering, ect.
     
  5. bongomania

    bongomania Gold Supporting Member Commercial User

    Oct 17, 2005
    PDX, OR
    owner, OVNIFX and OVNILabs
    No, I was describing problems that arise from poor design. So the solutions are (probably) not a quick soldering job. OTOH, if you want to pop it open and muck around with it, you'll probably get your money's worth from the learning experience.
     
  6. the vintage phaser definatly aint got that issue, neither does the bass overdrive, i just got them both this week and the only problem i have is that my epi t bird for some reason has its tone sucked out when i have the OD inline, the volume drops and has a nasty empty tone. doesnt happen with any other bass, single coil or bucker.
     
  7. I have the bass chorus and it does not have the problem either. :meh:
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.