FS: 1999 US Ampeg SVT-3 Pro (U Fix)

Discussion in 'For Sale: Amps, Preamps, and Cabinets' started by mfowlkes, May 4, 2012.

  1. mfowlkes

    mfowlkes

    Aug 30, 2009
    Cullman, AL
    U Fix Item

    I have a 1999 Ampeg SVT 3 Pro head that when the power switch is turned on, LED turns red and immediately turns off. It worked fine one day, then this happened the next day.

    A TB'r who used to work with Ampeg stated this - "It sounds like the "mute" circuit may have a problem, that is fairly well-known, and usually is broken solder joints. Other than that, a power supply problem, or loose solder on a tube socket are possible issues. No doubt there are more, these come to mind immediately."

    I do not have any ampeg reliable techs around me to take it to for service. I also have 4 other amps as this one sets in the closet. Im willing to make a killer deal to move this out of my home on to someone who can get it fixed and back to Rock-n-Rollin'. Its loaded with old Baldwin organ tubes which sounded killer when it worked. Also included with the sale is the Roadie brand 2-U ATA case.

    Disclaimer: This item is currently not in working condition and sold As Is! Pictures tommorow

    $215 shipped CONUS. No trades!
     
  2. mfowlkes

    mfowlkes

    Aug 30, 2009
    Cullman, AL
    Going up! Will accept best offer.
     
  3. saltwatertang

    saltwatertang Supporting Member

    Jan 15, 2012
    Louisville, KY
    PM sent
     
  4. mfowlkes

    mfowlkes

    Aug 30, 2009
    Cullman, AL
    Sold!
     

Share This Page