Future Impact Firmware Update Problem

Discussion in 'Effects [BG]' started by DanikDarko, Aug 7, 2019.


  1. I need some really basic help with the FI.

    I've connected my Saffire Pro 14 to my 2012 Macbook Pro running Mavericks and I've connected my FI to the interface using a Hosa MIDI cable (properly, meaning interface out is connected to FI in and FI out is connected to interface in) but there seems to be some issue somewhere.

    First of all, I'm not being able to update the firmware. I tried using the Chrome link that is there on their website but when it gets to the MIDI input and output page, both read "Not Selected".

    I downloaded the firmware (.ldr) file, opened the editor (the FI display shows "--5" and the dot keeps blinking), scrolled down the "File" tab and go to "Firmware Update" and select the .ldr file and then the 'display' on the editor reads "Connecting to FI..." and is perpetually stuck there.
    Subsequently, I realised I had to start the FI with both footswitches pressed down. I did that, the "On" LED was blinking slowly, I tried updating the firmware through the editor and LED started blinking quickly and the 'display' read "Loading Update...", left it over-night and it was still the same in the morning.

    I checked Audio & MIDI devices in Utilities and my Pro 14 is not greyed out. I've tried a "New Configuration" but no luck there either. I just cannot seem to understand what the problem is.

    There is audio when I use the pedal on its own. I can hear the changes in the patch when i edit anything on the editor but the display on the editor doesn't show the patch number and the program name is also empty and the display on the FI shows "--5" and the dot keeps blinking.

    I performed a complete reset as described in the Quick Start Guide as well but to no effect.

    Upon startup, the FI seems to be on the 2.03 firmware.

    Multiple computer restarts, unplugging and then replugging the midi cables, powering the device off and then turning it back on (powering it with a 1Spot) and this is still the case.

    Also, i'm not being able to save/load patches.

    Am I missing something?
     
    Last edited: Aug 7, 2019
  2. Highroler79

    Highroler79

    Apr 24, 2013
    any update?
    I am having the same issue
     
  3. TheBiggestBaby

    TheBiggestBaby

    Nov 8, 2013
    might be your midi connector. That happened to me. Ordered an Um-one and it solved the prob. There's list of acceptable interface in support doc. Good luck.
     
  4. Primary

    Primary TB Assistant

    Here are some related products that TB members are talking about. Clicking on a product will take you to TB’s partner, Primary, where you can find links to TB discussions about these products.

     
    May 22, 2022

Share This Page