1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

fuzz

Discussion in 'Amps and Cabs [BG]' started by StOneLiBeRaTiOn, Mar 17, 2005.


  1. I just got my new rig (ampeg b2-r with bse-410hlf) and when I turn it on there is a small hiss. I don't know if this is what is supposed to happen. I've never paid really close attention to this kind of thing till now when I actally have a rig worth playing out of. Pleast post
    thanks :bassist:
     
  2. I've tried this combination in a GC once and it hissed, but I thought that was because it wasn't set right or maybe the cab had a blown speaker.
     
  3. The speakers can't be blown because I jsut bought it. The tone I get from it sounds amazing but it just hisses when its on...
     
  4. TheChariot

    TheChariot

    Jul 6, 2004
    Boston, MA
    It's probably the BSE tweeter. Those cabs are really kind of suspect, as far as I'm concerned. I guess they will get the job done... but I wouldnt expect it to be amazing.

    Try turning down the tweeter or disconnecting it altogether... just as an experiment maybe.
     
  5. Yes you were right it was the tweeter. turning it off totaly elminates the problem but I lose the tone that i like, so i just turned it down and i get a happy medium.
    Thanks for the help!!!! :D
     
  6. Primary

    Primary TB Assistant

    Here are some related products that TB members are talking about. Clicking on a product will take you to TB’s partner, Primary, where you can find links to TB discussions about these products.

     
    Jan 16, 2021

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.