Dismiss Notice

Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

g/k 800rb help

Discussion in 'Amps and Cabs [BG]' started by pbassfreak, Jul 3, 2001.


  1. pbassfreak

    pbassfreak

    May 2, 2001
    long beach
    im having problems with my 800rb..it used to fart out alot
    then i had it serviced and it starting cutting out..i shipped it
    back to repair place and they said they gave it all the test and even an extreme test..they said everything checks out fine..this is a g/k service place..i put 250.00 into it..its still cutting out..should i blow it up on the 4th of july or any other suggestions would be very helpful..and its the older model i hear everyone wants
     
  2. winston

    winston Supporting Member

    May 2, 2000
    Berkeley, CA
    I don't know if you've seen any threads about problems with GK amps in the past, but a common malady is that the effects loop jacks crap out and make a really loud crackling noise-when you're not even plugged into the loop. I had a GK400RB head that had this problem. If you just connect a cable between the send and return jacks that should take care of it until you replace them (if that's what's causing the problem.)

    I've always liked the sound and layout of GK amps but about a year ago there were more than a few posts here about 1000RB's and 2000RB's going up in smoke while still new. They've since stopped making those and replaced them with the 700, 1001, and 2001RB's which seem to be more reliable. I hope you can fix your amp for cheap-or send it out in a blaze of glory!