1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)
  2. Because Photobucket has chosen to in effect "take down" everyone's photos (unless you pay them), we have extended post edit time in the Luthier's Corner to UNLIMITED.  If you used photobucket and happen to still have your images of builds, you can go back and fix as many of your posts as far back as you wish.

    Note that TalkBass will host unlimited attachments for you, all the time, for free ;)  Just hit that "Upload a File" button.  You are also free to use our Media Gallery if you want a place to create albums, organize photos, etc :)

G&L USA L2500 preamp wiring problem

Discussion in 'Luthier's Corner' started by mrpackerguy, Dec 1, 2005.


  1. mrpackerguy

    mrpackerguy Supporting Member

    Jul 3, 2004
    Madison, Wisconsin
    I am the new owner of a used G&L L2500. I've dated it to 1998. The preamp wasn't sounding responsive to me like my ASAT, so I opened up the back panel to change the battery and found 2 loose black wires near the bass control pot.

    I've never experienced a problem like this before. There is a G&L authorized dealer in Madison. I assume best thing is to just take it there for the repair. I don't own a solder gun.
     
  2. Bassic83

    Bassic83

    Jul 26, 2004
    Texas, USSA
    Yeah, take it in. Duct tape doesn't work so well on electronics... ;)