1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Gallien krueger 700rb ii shuts off randomly

Discussion in 'Amps and Cabs [BG]' started by soho192, Jul 16, 2014.


  1. soho192

    soho192

    Dec 31, 2005
    Chicago
    My amp has been doing this for some time now. I'll turn it off and then back on and it usually fixes it but not today. I have a power conditioner as well. Not sure what the deal is. Anyone have this issue before?
     
  2. wave rider

    wave rider

    Jan 5, 2005
    Too low impedance speaker load? Which cabinet(s)?

    =wr=
     
  3. Does the amp go dark, no light? That could be a faulty power switch. If the light goes from blue to red answer the post above first.
     
    wave rider likes this.
  4. wave rider

    wave rider

    Jan 5, 2005
    Good to see you posting, B-string!
    =wr=
     
  5. soho192

    soho192

    Dec 31, 2005
    Chicago
    Ampeg SVT 410HLF Should be fine regarding impedance. And yes it turns red before shutting off.
     
  6. soho192

    soho192

    Dec 31, 2005
    Chicago
    so obviously the intelligent protection circuitry is activating...just doesn't make sense. I've had this rig for at least 6 years now
     
  7. wave rider

    wave rider

    Jan 5, 2005
    Maybe one voice coil is shorting out? Can you try the cab with another amp?

    =wr=
     
  8. Damn right! :)
     
  9. soho192

    soho192

    Dec 31, 2005
    Chicago
    not really, I'd need another GK700rb to be consistent too
     
  10. wave rider

    wave rider

    Jan 5, 2005
    You could do the 9V test on the cabinet to see if all the woofers move same amount/direction. Given your post about using the 700II as a power amp, I'm wondering if it is getting too hot of an input.

    =wr=
     
  11. Thanks WR and Paul, I'll be missing for a couple days at least next week. Going under the knife and will be in the Hospital for a couple days. :)
    Back to the program........shutting off is still strange. The unit should remain in protect until he fault is cleared or you shut it down as far as know. you can eliminate a cab problem by firing up the amp with no cab connected, if it still acts up it is not the cab. This is an unusual case in my experience I would send an email to jason@gallien.com he is artist relations and once or still may head the service department at GK. He is always friendly help.
     
  12. Ah! Finally going in for that pecker reduction you've been talking about?
     
    B-string likes this.
  13. More seriously my friend, hope everything goes as planned. Good luck and clue us in ASAP after.
     
  14. Could be something's screwy in your power conditioner. This might limit current which might put the amp into Protect. Lotta 'Mights' but easy to try amp without conditioner.
     
  15. Having to lift that sucker was killing my back ;). Thanks Paul, I will check in as soon as I am able (and can make some sense?).
     
  16. Art Araya

    Art Araya

    May 29, 2006
    Palm Coast, FL
    Overheating? I had this problem when I didn't allow some space between the head and other components.
     
  17. Highroler79

    Highroler79

    Apr 24, 2013
    I have a RB 1001Rb I believe it is the 2 version and at practice today the amp died. The lights don't come on, and the fan is not running. I have the Amp in a Deep road case 3U with a Power regulator above the amp. Would that case problem I know they say to allow 1u above the amp but the road case is deep and the Fans above the amp are not covered? Any advise would be great
    thx
     
  18. Highroler79

    Highroler79

    Apr 24, 2013
    I have the amp at home now and am gonna try it again later and check the fuse, if anyone know anything else I can check that would be great
    thx
     
  19. soho192

    soho192

    Dec 31, 2005
    Chicago
    I checked out the speaker cable and there were some fringed wires. I bet they may have vibrated enough to short it out. I trimmed the excess and haven't had any issues.

    High roller. Try plugging the amp into the wall instead if through the conditioner.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.