1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

GK 400RB amp repair ideas

Discussion in 'Amps and Cabs [BG]' started by renejaime, Apr 17, 2006.


  1. renejaime

    renejaime

    May 25, 2005
    Austin
    I have a 90's GK 400RB that sounds great but has to what seems like "warm" up for about 2 - 5 mins. That are I have to kick the volume up all the way for a bit then it comes to life, then at low volumes it will go in and out from time to time. Does anybody have any experience with this?

    A GK 400RB has always been workhorse for me, I sold my original 400RB and missed it so much I bought this current one used and shortly after I started experiences these problems.

    thanks
     
  2. tplyons

    tplyons

    Apr 6, 2003
    Madison, NJ
  3. renejaime

    renejaime

    May 25, 2005
    Austin
    thanks for the email link will give it a try...
     
  4. Trevorus

    Trevorus

    Oct 18, 2002
    Urbana, IL
    Sounds like it could be a bad volume pot or something of the sort. But, TP (haha) is right. E-mail GK. They are usually pretty helpful.
     
  5. winston

    winston Supporting Member

    May 2, 2000
    Berkeley, CA
    A trip to the GK factory brought my '87 400RB back into great working condish after "fixes" by local techs couldn't. One common malady on GKs from this era is corrosion in the FX send/return jacks that can cause intermittent signal and what appear to be volume/power surges. Try cleaning the jacks with contact cleaner and see if that helps.
     

Share This Page