1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

GK 700 RB-II Clipping/Distorting?

Discussion in 'Amps and Cabs [BG]' started by Freaky Fender, Feb 24, 2008.


  1. I just got a GK 700 RB-II head, and when I turn the "Volume" knob by the input jack up to about 3 o clock, there's a distorting going on in the head. It's fine if I keep the volume knob on 1 o clock or so, but any more than that it just distorted. What's going on here? The clip light doesn't come on, but is this the head clipping?
     
  2. fenderhutz

    fenderhutz Supporting Member

    Jan 28, 2007
    Harpers Ferry WV
    It's called overdrive, it's supposed to do that. Make sure yur boost knob is turned off for less overdrive.

    Turning the volume knob to max is a good way to destroy a cab due to sending clipping signals.
     
  3. Yeah, ok, hurf durf. I tried it with my guitar and I didn't notice.

    It wasn't at max, it was a little over halfway.

    I guess I just though it was not really suppose to saturate the preamp that quickly.
     
  4. Vic Winters

    Vic Winters Supporting Member

    Apr 20, 2006
    Rochester, NY
    GK manual states the OD effect starts after the noon position on the Input Volume. Also, the Clip LED is wired first in the amp, so you could turn the Input Volume all the way up, and it won't register on the Clip LED. But I highly suggest you don't do that.
     
  5. Warfrat73

    Warfrat73

    Nov 18, 2007
    Milwaukee
    That's the input level knob. If you actually want to adjust the volume you should use (primarily) the "Woofer" knob in the output section. You might want to download the manual from GK and give it a read
     
  6. Forcemaster

    Forcemaster Supporting Member

    Jul 15, 2006
    Portland, OR
    +1 the max I ever need to run my input knob is 10 o clock, with woofer knob at around 12/1 o clock.
     
  7. jtc_hunter

    jtc_hunter

    Feb 16, 2007
    yep-, woofer at 3:00, input volume at 10 or 11:00
     
  8. Jeez, I actually did read the manual, but I guess I have to go back a look at it. :(

    I swear I searched before this thread, but a lot of times the threads stating that they have problems are, how shall I put it, written less than proficiently?
     
  9. gkbass13

    gkbass13 Supporting Member

    Mar 29, 2006
    Chicago
    i have a gk 700rb and have been getting some hiss/fuzz /distorted almost staticky noise from the horns on my epifani cabs when i play. the inout volume is also a bit scratchy when i adjust it. coudl it be a cleanliness issue? as the amp is probabaly over 10 years old.

    what would be causing that noise from the cabinets? both are in pefect shape and one even has a brand new foster horn. i only play with the tweeters turned to about 11 oclock on the cabs. my current setting on the gk head are: contour 2 oclock presence 10 oclock, treble 11 oclock, high mids 11 oclock, low mids 12 oclock and bass 12 oclock.
     

  10. As for the volume pot, that is most definitely a dirty pot.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.