Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

GK 700RB combo problem

Discussion in 'Amps and Cabs [BG]' started by Murf, Aug 16, 2005.


  1. Murf

    Murf

    Mar 28, 2001
    Ireland
    Hi Guys/gals,
    I've been playing through a 700rb (2x10) combo and I recently noticed a strange hissing sound coming from it, even when my bass is unplugged, it kinda sounds like the crackle/hiss you get with bad pots but when I play it for a while the hiss seems to go away :confused:

    Also I've noticed recently that I'm having to push the volume more and more to hear the damn thing at gigs..I normally end up with the woofer & boost at 3 o clock and volume at 12 o clock and at this stage the speaker(s) is starting to distort like crazy.

    This is really bugging me as I keep reading about how punchy and loud these combos are but so far in a gigging environment (using it as backline) I'm just not hearing it.....are my speakers dodgy??

    (I recently did a gig with a crappy(ancient) trace elliot 15' combo and that was putting out a hell of a lot more volume and low-end than my GK...surely this cant be right??)

    Any help much appreciated

    cheers
    Murf
     
  2. Murf

    Murf

    Mar 28, 2001
    Ireland
    Bump
     
  3. Is it under warranty? You should contact GK tech support. I think you might have an amp board going out or something.
     
  4. Murf

    Murf

    Mar 28, 2001
    Ireland
    Thanks for the reply Daniel, unfortunately (as far as I'm aware) the warranty is up as I bought it over a year ago. The thing is I have barely used it since I bought it as 90% of the gigs I was doing were either recordings or tv (which were straight DI jobs) its only recently where I'm doing a lot of "depping" with various bands that I'm using it and its just not performing right..which is really bugging me because I paid a lot of money for it at the time and for a so-called "high-end" amp I expect a lot more.

    It's doubly frustrating because every review I read about it give it a glowing score..sorry I dont see/hear it, I'm using it as more or less a monitor as every gig I do I take a line out from the di to the desk..but its practically useless as a monitor because I cant hear it on stage.

    Another thing I've noticed is that as the gig progresses the volume/tone gets worse and worse..its like the power is being "leeched" somewhere..I suspect the di but I'm no expert on this..

    Maybe the amp I got was defective from the start I dont know but if anyone has any ideas where I go from here I'd much appreciate them. (the annoying thing is its potentially an excellent amp if it would only work as its supposed to :(
     
  5. If you bought it new less than 2 years ago, then it's still under warranty. Even if it's not, I'm sure Gene can help you get it fixed at a reasonable cost. contact gene@gallien.com
     
  6. Murf

    Murf

    Mar 28, 2001
    Ireland
    Thanks for the contact Daniel, much appreciated. :)



    cheers
    Murf