Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

GK Backline 115 -- fails to start sometimes

Discussion in 'Amps and Cabs [BG]' started by millard, Dec 8, 2004.


  1. millard

    millard

    Jul 27, 2004
    SoCal
    I press the ON switch on my amp and the little red light comes on, letting me know it is getting ready for me (it goes green after it has powered up and engaged the speaker). Every once in a while, I turn back to it and it is off, as if I had never touched it.

    When I press the button again, more carefully this time, it always comes up and works fine. I've never seen the green light and then had a problem. The power pushbotton control is a bit "counter sunk", so it is possible that I don't push it enough on these occasions and that it is all operator error.

    But maybe it is something else...

    Thanks...Millard
     
  2. Eric Moesle

    Eric Moesle Supporting Member

    Sep 21, 2001
    Columbus OH
    When's the last time you changed the oil????

    Seriously, it sounds just like a bad switch. Keep an eye on how far you depress it, and if it continues, you can replace the switch pretty cheaply if its no longer under warranty.
     
  3. millard

    millard

    Jul 27, 2004
    SoCal
    I tried it to make sure and it isn't a bad switch press. The power/protect light won't come on unless the switch "clicks". So it is going through some sort of startup process and decides not to bother every once in a while. Could it be too cold? Perhaps I should get it a blanket...

    Thanks...Millard
     
  4. rusmannx

    rusmannx

    Jul 16, 2001
    try an "all tube" switch. that should not only fix you up nicely, but increase your tone as well.
     

  5. not if you don't like tube amps :D