1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

GK MB 150

Discussion in 'Amps and Cabs [BG]' started by Mavrik9007, Aug 22, 2012.


  1. Mavrik9007

    Mavrik9007

    Jul 17, 2011
    This little Amp goes for about 45 min or less than starts losing power.. cutting out.. Ive used it exclusinvley fro string bass for years but now theres this problem. I m not getting much help from local amp tech. Intermiittent problem difficult to trouble shoot ? Any hear of these litte amp having this issue and how do ya fix it?
     
  2. Also used an MBE150E for years with upright and loved it.

    Does "losing power" mean it shuts down/powers off or does the sound cut in and out? If the amp powers off, have you tried a new/different power cable? I had a problem with a GK 700RBII which would intermittently and spontaneously turn off. A new power cable, oddly enough, seems to have resolved it.

    If the sound is cutting in and out, there are postings on this forum about corrosion build-up in unused send/receive jacks possibly causing problems. I have no experience with this, but it might be something to rule out.
     
  3. shastaband

    shastaband Supporting Member

    Dec 12, 2006
    Yes, I had the same problem with mine cutting out in mid-rehearsal. Temporary fix is putting a short patch cable between effects send and return. Permanent fix involves cleaning/replacement of the switching jack in the effects send circuit.
     
  4. Clean all the jacks - expressly the effect send/return jacks with De-Oxit cleaner.
     
  5. musicman5string

    musicman5string Banned

    Jan 17, 2006
    I've had the exact same issue and the amp repair guy couldn't diagnose the problem. I've had my GK since 1995 and this just began happening recently. All the inputs and fuses were replaced.....
     

Share This Page