1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

GK1001rbh Combo Problems

Discussion in 'Amps and Cabs [BG]' started by Ankles, Feb 14, 2002.


  1. Ankles

    Ankles

    Jan 6, 2001
    BostonMA
    I bought a GK1001RBH 2X10 combo (or have tried). The one out of the box smoked as soon as I played my first note. Back to the store and got another one. This one the power amp works but,speakers dont work.

    I had bought a 1000GK head a few years ago but, it kept blowing. Intermittent fail. I got rid of it.

    Recently after busting my back witht the old SVT I decided to give the GK1001 2x10 combo a whirl. Iam not comfortable putting my faith in this unit.

    Has anyone else experienced theses issues? Has any one dealt with GK to maybe make me a little more comfortable with this pricey little unit?

    Thanks All
     
  2. CrawlingEye

    CrawlingEye Member

    Mar 20, 2001
    Easton, Pennsylvania
    G-K's have a lot of notable problems.
    I've heard something with the i/o's?

    I've never heard of your speaker problem, but from what I gather the poweramp problem isn't unusual for G-K's. From what I gather, if you play the amp for 1-2 hours at the store, and it works well, it should be fine.

    Usually most problems that people have had with G-K's have seemed to be within the first few hours of playing. :)