Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

Guyatone Br-2 Wah-less

Discussion in 'Effects [BG]' started by Sako, Aug 25, 2005.


  1. Sako

    Sako

    Nov 4, 2004
    Charlotte, NC
    Just got a BR-2 from MF. The package was bent up pretty bad. The pedal seemed fine, but when I hooked it up, no wah. Plenty of bass -- as a matter of it seems to add bass. But no wah -- doesn't sound like an envelope filter at all. I checked out some of TaySte's BR-2 sound clips, and thought they were pretty cool.

    Anyone have this happen to a Guyatone pedal? Well, guess it's back to Musicians Friend.
     
  2. syciprider

    syciprider Banned

    May 27, 2005
    Inland Empire
    Just curious, what's the construction like?

    Thanks
     
  3. Sako

    Sako

    Nov 4, 2004
    Charlotte, NC
    Well first, this was a buy-before-you-try purchase. I figured with MF's return policy, I couldn't go wrong. The construction seems tough enough. Two things, the bottom plate is flush with the bottom of the pedal, and a robber strip, kind of like a rectangular o-ring with a groove in it, holds them together. This concerned me at first, but I baby all my equipment, so it's no big deal. The other thing was the battery -- loose in the pedal. Grant it, there really is no spare room, but I wondered if it got knocked up against the circuit board.

    When I turn the decay knob, I can tell it's working, a little bit anyway. But when I turn the threshold knob, nothing happens.

    This pedal, obviously not working properly, adds a LOT of bass. I'm wondering if it was working correctly, would there be too much bass?

    Oh, and I realize why they call this the micro series -- this thing is small!
     
  4. TaySte_2000

    TaySte_2000

    Jun 23, 2001
    Manchester, UK
    Endorsing Artist: Mojohand, Subdecay, Overwater, Matamp
    This pedal adds loads of bass thats the beauty of it, and why it sounds so unique.

    Basically the way I set it was keep playing open e while turning the threshold knob when i hear the filter open I leave it and then set the decay. This pedal also doesn't like a massively hot input so try turning your volume down as well.

    Hope this helps
     
  5. Flea666

    Flea666

    Apr 21, 2005
    Lichfield, UK
    i think i had the same problem, i brought TaySte's and i took 2 my local music shop and they guy figured out that, i needed more mili amps on the adapter i was using, it needs like over 400 or sommit, so it cud b that
     
  6. TaySte_2000

    TaySte_2000

    Jun 23, 2001
    Manchester, UK
    Endorsing Artist: Mojohand, Subdecay, Overwater, Matamp
    It only needs 15 ma's
     
  7. Flea666

    Flea666

    Apr 21, 2005
    Lichfield, UK
    oh, cud of been my adapter then i dunno.
     
  8. Sako

    Sako

    Nov 4, 2004
    Charlotte, NC
    I'll give that a shot first. I have a passive Jazz, and I did try various volume levels. I'm thinking it will still have to go back. We'll see.

    Thanks TaySte and Flea.
     
  9. NicJimBass

    NicJimBass Is this thing on!? Supporting Member

    Nov 22, 2004
    Lancaster, OH
    Endorsing Artist: DR Strings, Source Audio, Hipshot
    I was less than impressed with this as well. Not much wah. Of course, I put it head to head with a Q-Tron, which eats it for lunch. I was hoping for the opposite.