1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Hartke 4.5xl high-speaker blown?

Discussion in 'Amps and Cabs [BG]' started by krstko, Dec 16, 2011.


  1. krstko

    krstko

    Aug 29, 2011
    Cerknica, Slovenia
    Hi!
    I was practicing with my Hartke half stack and suddenly a really high tone came out of my bass (no idea why). It was so loud it made my ears hurt and really high. I turned my amp off after few seconds. I took my second bass and with it everything was normal, except I felt like I have lost my treble. Is it possible that I blew my high-speaker or is this no-treble sound just in my head?
     
  2. will33

    will33

    May 22, 2006
    austin,tx
    Without playing, turn the amp up and crank the upper mids and treble way up. Should hear at least a little hiss coming from the HF driver.
     
  3. murphy

    murphy

    May 5, 2004
    Toronto, Canada
    Yeah, i toured one that had its' little speaker blown.
     
  4. krstko

    krstko

    Aug 29, 2011
    Cerknica, Slovenia
    ok, I'll try that ..and if I don't hear anything I'll just get a new one :)
     
  5. I'm not sure but I would think that if you hear nothing then it isn't the speaker, it is the crossover or a bad connection. A bad speaker will still make horrible noises AFAIK.
     
  6. krstko

    krstko

    Aug 29, 2011
    Cerknica, Slovenia
    I don't think just a loud tone that last for few seconds would blow a crosscover or melt the wires :)
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.