HELP! GK 800 RB problem

Discussion in 'Amps and Cabs [BG]' started by keepmusicevil, Aug 6, 2003.

  1. keepmusicevil


    Jul 1, 2002
    San Diego
    Was playing last week, when I plugged my cable from the amp to the bass, a puff of smoke came from the power switch (rocker-type). Now it don't work. I will take it in to have it looked at, but was wondering if anyone here had heard of/seen this before.
  2. thumbtrap


    Jun 26, 2003
    Yes. Electronics run on smoke. If you let the smoke out - they don't work any more.

    In all seriousness, there isn't really enough here to diagnose the problem except for the obvious. The good news is that with electronics, catastrophic failures are much easier to diagnose, and sometimes easier to fix than milder problems.

    Check the obvious first though, and make sure it's not a fuse. It sounds like something else decided it would rather be a fuse.
  3. keepmusicevil


    Jul 1, 2002
    San Diego
    The day before, i pushed the switch up, and as soon as i took my finger away, the power disappeared, but the switch was in the up or on position. I then rocked the switch down just a bit, and the power stayed on. Went to plug in and.......well, you know.

    I took off the top cover, and went in to look at things. Seems the positive and neg. terminals that plug into the back of the switch are strange. One has a little bit of freeplay, while the other as stiff as a board.

    Maybe a bad switch? Fried the power supply?

    Thanks in advance for any help or information you have.