Discussion in 'Amps and Cabs [BG]' started by Bayou_Brawler, Feb 22, 2006.

  1. Bayou_Brawler

    Bayou_Brawler The most hurtful thing ever realized

    Oct 23, 2003
    Ann Arbor, MI
    So my 800RB GK amp is acting up.

    Volume goes in and out. It was even putting out volume when I had the volume on 0???:confused: and it just sounds crappy.

    HELP! anyone know what it could be??????

  2. Steve


    Aug 10, 2001
    The fact that it puts out sound with the volume knob off is kind of telling.

    I'd take a good hard look at that volume pot. Spray the dookie out of it with some cleaner, tap on it a couple of times while tha amp is turned on and see if that has any effect. If it does, I'd replace the pot.
  3. Metal Mitch

    Metal Mitch

    Jul 14, 2003
    First thing I would do is line up another amp to use for the gig. Because it could take some time to troubleshoot and repair your 800RB.

    I have 2 guesses... bad volume pot, or a capacitor shorting to ground once it loads up. That happened to my old Acoustic 370 head. Volume was going up and down, wouldn't just stay on. Opened it up and saw a big spark from the large cap was jumping over a cold/cracked solder joint to ground. So it only happened once the cap charged up to a certain level. Then it would ground and recharge. Resoldered the joint and all was good.

    Of course that may have nothing to do with your GK's problem... know of a good amp shop in your area? Try contacting GK tech support too.
  4. Vic

    Vic There's more music in the nuance than the notes. Gold Supporting Member

    Oct 14, 2002
    Central Illinois
    Staff, Bass Gear Magazine
    Just a thought...

    Got a pre/DI box you can plug into the power in? Might get you past the gig AND teach you something about the failure...