1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

Help! Is my PLX sick??

Discussion in 'Amps and Cabs [BG]' started by Jim Ingraham, Apr 26, 2005.


  1. Jim Ingraham

    Jim Ingraham Supporting Member

    Nov 14, 2002
    Shillington
    This is something i have not noticed before with my B-Max into my 1602. When i have the amp set in paralell mode, one GS112 plugged into each speaker output, i notice that when i have just one channel gain turned up the speaker sounds normal, but when i turn up the second channel gain to match the first, i have net loss of volume and especially bass response in both. :confused: :confused:

    Turn either channel down and the remaining channel returns to normal. I also tried this in stereo mode using a splitter out of the BMax. Same result. Is my PLX going bad or is this normal??
     
  2. It might not be a problem with the amp. Sounds like there might be phase cancelation between the two cabs. Did you check to see if the cabs are wired out of phase to each other?
     
  3. Jim Ingraham

    Jim Ingraham Supporting Member

    Nov 14, 2002
    Shillington

    Dude!! your the Man!! exactly what happened ..ive been using an older speaker cable i dont normally use as i lost my regular one. And of course it was wired backward :oops:

    thanks for your help :bassist:
     
  4. WOW..I was right? :eek:

    Well, looks like Im done for the month! :D