1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Help! My Ampeg SVT 350 won't power up

Discussion in 'Amps and Cabs [BG]' started by arginator, Mar 21, 2009.


  1. arginator

    arginator

    Feb 28, 2009
    Upstate NY
    Anyone know what might be wrong with my ampeg svt 350? It quit on me at last night's gig. Worked fine for the first few minutes of soundcheck. I turned it off to switch cords, and then back on, but nothing. No sound at all, no lights, nothing. Bass was working fine. Tried new power cord, different outlet, replaced the fuse, but nothing worked. I ended up going direct through the PA.

    Before I bring it in for repair I'd like to have some idea of what might be wrong with is so I don't get ripped off.

    Any ideas? Thanks!
     
  2. Start with a $10 power switch and end with a $200 transformer, lots of other possiblities along the way.
     
  3. arginator

    arginator

    Feb 28, 2009
    Upstate NY
    Thanks. Anyone out there have the same problem with this amp?

    Anyone know where I can find parts?
     
  4. anderbass

    anderbass

    Dec 20, 2005
    Phoenix. Az.
  5. arginator

    arginator

    Feb 28, 2009
    Upstate NY
    Thanks for the info! I took it apart with a friend today, and turns out it was just a loose connection that needed to be resoldered.
    And its working again, so far....
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.