Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

Help, Peavey TKO 115

Discussion in 'Amps and Cabs [BG]' started by gowerski, Dec 27, 2000.


  1. gowerski

    gowerski

    Nov 27, 2000
    Ummm Hi.

    Recently I got a Peavey TKO 115 (i think it is 1993 or 95)bass amp to use with my washburn force abt bass (active bass). But my amp has a buss that is constant no matter if my guitar is plugged in or not and it stays at the same volume no matter how loud it is turned up.

    Hopefully you can help. thanks.
     
  2. gowerski

    gowerski

    Nov 27, 2000
    I think I fogot to mention it is a bass combo 80 watt with a 15" black widow speaker.

    k bye again
     
  3. pkr2

    pkr2

    Apr 28, 2000
    coastal N.C.
    gowerski

    If the buzz is still coming through the speaker with the volume turned all the way down on the amp the filter caps in the power supply are probably going bad. It would be a good idea to get it repaired before you use it any more. A power supply problem in a solid state amp can take out a lot of parts.

    Good luck, Pkr2
     
  4. Wxp4759cb

    Wxp4759cb

    Nov 23, 2000
    Kansas City, MO
    Check if the nut on the input jack is coming loos, if so just tighten it, it used to happen all the time to one of my old amps.
     
  5. Gabu

    Gabu

    Jan 2, 2001
    Lake Elsinore, CA
    You might try moving the amp somewhere else and plug into a different circuit. I have that problem when I play in my garage because my garage is not well grounded.