1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Help: Trying to Troubleshoot an old Peavey Amp

Discussion in 'Amps and Cabs [BG]' started by Sir Edward V, Sep 16, 2008.


  1. Sir Edward V

    Sir Edward V Not Actually Knighted... Yet!

    Dec 11, 2006
    Massachusetts
    So we have this old Peavey PA that we used to use with my old band for practice. Now me and my friend want to use it to practice with a new band, but it is having some problems. Being the DIY Electronics type of guy I am, I want to fix it myself. Here is the problem:

    If you tap the head with light amounts of force, it sounds like it is shorting out somewhere and makes a horrible and loud crack. It also does this if you are plugged in and playing with the head on top of the speakers.

    I opened it up, and I was able to determine the sounds are coming from the second of 2 circuit boards, which is the circuit for the power amp. So I started tapping around on the circuit board (with a drum stick) very lightly to see where it most easily made noise. (I know, cave-man electronics testing). it seams to make that loud crack most easily when I tap around/on these large capacitors, which is near the transformer.

    Has anyone heard of problems like this or what these problems could be coming from? Any help would be nice. and yes, I have a multimeter, I tested some things and everything I have tested looks good.
     
  2. sub b

    sub b

    Sep 14, 2008
    probably loose solder joints thats all
     
  3. Sir Edward V

    Sir Edward V Not Actually Knighted... Yet!

    Dec 11, 2006
    Massachusetts
    I've been looking around and nothing is obviously loose...
     
  4. BbbyBld

    BbbyBld

    Oct 13, 2005
    Meridian, MS
    That's very likely.

    Here's something else...check out the connectors that connect to the power amp board. The female pins of the connectors will sometimes spring open causing a loose connection. You can tighten them back with a small screwdriver or something similar.
     
  5. fdeck

    fdeck Supporting Member Commercial User

    Mar 20, 2004
    Madison WI
    HPF Technology LLC
    I find that a bright flashlight and magnifying glass are helpful in finding cracked solder joints. Also, any force that cracks solder could also put a hairline crack in a circuit board.
     
  6. Sir Edward V

    Sir Edward V Not Actually Knighted... Yet!

    Dec 11, 2006
    Massachusetts
    hahahaha, yeah, this PA is too old to have the screws to tighten them back up... their just kinda in there.

    I think this PA was built circa 1978...

    I just checked the pins and one looks questionable, so I will try fixing that tomorrow. time for bed

    thanks for the help thus far though
     
  7. Most likely dirty pots ... I had an old Peavey Super Festival Series F-800B that I used to have to the pots apart every 6 months to clean them up. Otherwise it would pop & crack like a mofo until it got the proper attention.

    I just pryed the tabs loose, and cleaned everything with foam swabs & alcohol, then reassembled them. However, my electrician buddy said that there is a spray that you can use to do the same thing without taking the pots apart. Go figure!!!

    Otherwise unplug any connectors & check for dirt/corrosion and plug them back in.

    My 2 cents!
     
  8. Chuck King

    Chuck King Supporting Member

    Dec 15, 2006
    Chicago
    I had that exact problem with an old Peavey Mark IV Bass head last year. The plug where the wire connected the preamp board to the power amp board had come loose. I thought the whole thing was fried, but cleaning and tighening that connection brought it back to life like nothing had happened.
     
  9. Sir Edward V

    Sir Edward V Not Actually Knighted... Yet!

    Dec 11, 2006
    Massachusetts
    I highly doubt that. its not cracking when I turn the pots. I know about that problem, I have it with my bass.

    but I need a better soldering Iron to work on this beast... I thinking this thing is ready to be scrapped. Its weak anyways, it only puts out 130 watts at 4 ohms, when I have 2 speaker cabs for it that can each handle 300W at 8 ohms... waaaayyy underpowered
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.