1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

Help

Discussion in 'Amps and Cabs [BG]' started by black4string, Apr 9, 2006.


  1. If anyone could help me, two of my amplifiers are grounded.
    when i turn it on, all you hear is ground, and even if you plug in a guitar, it still sounds the same. Grounded.
    I can't get any sound from my amp but the ground.

    I took one to an electronics shop, and they said that it was the I.C.
    Thec replaced the I.C. and they tested it.
    The ground was gone, but they didn't turn any of the knobs.
    When i got home, excited to try it out, i plugged it in.
    By the way, the amp i'm talking abot is a Fender Bassman model BM-20CE and is a 110 voltage amp.

    After plugging it, and plugging my bass, i turned the volume up and BOOM.
    Something inside popped and the smell of burnt electronics filled the air.
    I quickly brought it back to where i got it fixed, they took a look at it and saw the new I.C. Busted real bad.
    They gave the conclusion that i plugged it in a 220 socket.
    But i plugged it in a 110 Transformer.

    Being pissed at their stupid and hasty descisions, i just went home and put the amp aside.

    Having no money to take it to an official fender place, i could'nt do anything to fix both my amps.
    plus, it's very hard to find an authorized fender place in the Philippines.

    The other amplifier is a squier model SQ B 15.

    Both have the same problem.
    Any help would be much appreciated.
    Thanks.
     
  2. Have you tested your transformer to make sure that it has no fault and that it is wired correctly? If the transformer is OK and wired correctly, there may be a fault in the power supply part of your amp. It usually takes some sort of wrong voltage or short circuit to cause a chip to fry, unless somebody installed the chip backward.

    Those are the thingsI would check.
    1. Transformer and the wiring of both sides of the transformer.
    2. Power supply circuit in your amp.
    3. Were repairs that were made done properly or possibly were they trying to fix the symptom of the problem without fixing the real problem

    Best of Luck,
    S
     
  3. 1. the shop checked my transformer and it has an output of 120 volts. they say that that's too much already, but my highschool electronics education does'nt say the same thing.

    2. I'll go check it out

    3. I think they were amateurs, because upon hearing my problem, they hastily concluded that it was the I.C.
    I think thay only fixed the symptom but not the problem itself.

    Thanks for the reply, i'll update you about the power supply
     
  4. How i test the transformer with a multitester or multimeter?
    sorry, but i really don't know how..
     

Share This Page