1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

Hi from Austin TX. Newcomer with G-K MB150E Problem

Discussion in 'Amps and Cabs [BG]' started by TyeDyeJohn, May 13, 2006.


  1. TyeDyeJohn

    TyeDyeJohn

    May 13, 2006
    Hi! Just joined! :) Happy to be here, but :confused: I've got a Bass Amp (G-K MB150E Series III Combo) problem I don't really think anyone can help with, but here goes. It's brand new and on the 2nd gig, it was turned ON, and our drummer unplugged, the replugged power strip I was in, (2-3 seconds) and amp would no longer turn on! Period! Nothing! It has no user servicable parts (fuse, reset, etc.), and I've got 3 days to find advice or answer, before I take it back to exchange for another New one (7-10 day wait :crying: for shipping through Guitar Center). Has anyone had this happen? Did this action do some damage?
    There is nothing in the Manual about a "not pulling the plug" danger! A short power outage could happen anywhere, so I am concerned about the future, even with another New one! Any of this ring a bell? Maybe I just got a Lemon! I will take it back on Monday, if I hear nothing!
    A Sincere Long Shot,
    TyeDyeJohn, Austin, TX.
     
  2. anderbass

    anderbass

    Dec 20, 2005
    Phoenix. Az.
    Drummers......There might be a fuse or reset inside the amp, but if you go digging around, you might void your warranty or worse.


    Your amp probably would have survived this outage if you could have flipped your powerswitch off, before he restored your power, or possibly if your power had been cut off, for a longer period of time.

    That 2 or 3 second power interuption had your amp trying to hick-up, cough, berp, sneeze and fart, all at the same time...:eek:
    This is defenetly somthing I would try to avoid from happening again...:meh:
     

Share This Page