1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

HipShot BT-2 on Fender AV'75 Jazz?

Discussion in 'Basses [BG]' started by esa372, Mar 13, 2013.


  1. esa372

    esa372

    Aug 7, 2010
    Hi, TB.

    I just put a HipShot BT-2 "Bass Xtender" on my AV'75RI Jazz, and I noticed that the back plate hangs over the edge of the headstock a bit.

    HS-BT2.jpg

    It's not very much, but it's enough to be annoying.

    I'm wondering if this is normally how they fit, or if there's something amiss. (According to the company info, the BT-2 is for original and reissue USA '67-'82 Fender P & J Bass, so this should be the correct model.)

    Anybody out there have a mid-70s (original or reissue) that has a BT-2 on it? Is this how yours looks?

    Thanks!

    ~esa
     
  2. esa372

    esa372

    Aug 7, 2010
    ***bump***

    :help:
     
  3. SirMjac28

    SirMjac28 Patiently Waiting For The Next British Invasion

    Aug 25, 2010
    The Great Midwest
    Could it be a misshapen headstock?
     
  4. esa372

    esa372

    Aug 7, 2010
    Wouldn't that be a bit peculiar? Aren't they all CNC now?

    I suppose it's possible, but it seems to be identical to others I have owned or played.

    Thanks for the reply, btw. :)
     
  5. normal.
     
  6. esa372

    esa372

    Aug 7, 2010
    Really?

    Since starting this thread yesterday, I have contacted HipShot about it, and they said, "This is definitely a first."

    narud, how do you know that this is normal? Do you have '70s Jazz basses with the BT-2 installed? Do you have any more info or insight?

    I'm just trying to find out what the deal is here... :meh:

    Thanks!
     
  7. i had the same bass with a hipshot and the corner poked out like that.
     
  8. *pr1mo*

    *pr1mo*

    Feb 18, 2009
    Support and Machinist, Hipshot Products, Inc.
    I'm curious, can you see the plate when the lever is in the "hi" or "e" position? If not, it could simply be the swivel plate in the rotated position. Or is it the base plate hanging off all the time?
     
  9. esa372

    esa372

    Aug 7, 2010
    Thanks!

    It's the base plate - it shows in either position.

    I see that you work for/with HipShot - do you have any suggestions or insight?

    Thanks!
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.