1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Hiss issue with Active spector

Discussion in 'Pickups & Electronics [BG]' started by mamiedenise, Jan 17, 2019.


  1. mamiedenise

    mamiedenise

    Jan 17, 2019
    Hi ,
    for a while I have a sound problem with my active bass. It's a spector Ian Hill signature. An active bass with emg p&j pu.

    Sometimes the sound is very clean with almost no noise, even with high at maximum and a moment later i have a lot of hiss.

    When the problem occurs :
    if i touch pu's scews or some screws at the back, there are less hiss
    if i touch strings or bridge nothing happens
    If i touch the preamp, there are more hiss

    It's getting worse with time.
    Is it a ground or wire issue ? Or maybe the pu and or the preamp ? I'am not good in electricity. So if you have advices and experiences with such problems that could help me to figure what's wrong and how to fix it , I will appreciate.

    mamiedenise
     
  2. Primary

    Primary TB Assistant

    Here are some related products that TB members are talking about. Clicking on a product will take you to TB’s partner, Primary, where you can find links to TB discussions about these products.

     
    Feb 24, 2021

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.