1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

Hiss on the effect chain

Discussion in 'Effects [BG]' started by badboy1984, Apr 22, 2009.


  1. badboy1984

    badboy1984

    Mar 27, 2007
    United Kingdom
    I was wondering what causes the hiss on the effect chains?

    Problem with the power or the pedals?

    I can hear hiss on the cabinet since i play right next to the cab and amp, but if i play it loud is not a problem since i won't be able to hear it.
     
  2. bongomania

    bongomania Gold Supporting Member Commercial User

    Oct 17, 2005
    PDX, OR
    owner, OVNIFX and OVNILabs
    There are loads of causes. Try isolating the chain one pedal at a time, one cable at a time, and see if any one of them is to blame. Then tell us what it is and exactly how you have it connected to your chain and the power supply. If you do that carefully, and it turns out that it isn't just one pedal or cable, then describe the entire chain and how they are all connected, including power supplies.
     
  3. spunj13

    spunj13

    May 14, 2007
    niles, mi
    i had this problem recently too, and discovered that it was most definitely my power.
    i have an old power brick (can't even remember the brand) and it was giving off dirty power... no good.
    my one-spot is surprisingly quiet though...

    just need 2 voodoo pedal-powers instead.

    but... definitely deconstruct and see if it could be just one pedal making the noise.

    [spunj13]
     
  4. dannybuoy

    dannybuoy

    Aug 3, 2005
    England
    I had this problem and narrowed it down to my Multicomp. It's a process of eliimation, removing/soloing pedals and trying each one on a battery vs power supply.
     
  5. badboy1984

    badboy1984

    Mar 27, 2007
    United Kingdom
    I have 6 pedals and here are the order i chain them:

    Boss Tuner --> Boss compression --> Boss Limiter --> Digitect Chorus --> Bass Crybaby --> MXR M80

    No more hiss now after doing some testing.

    I put the batteries back in the LMB3 and the Crybaby and the hiss is gone, but i still power the two using PSU, so i guess i have to leave a battery in their to make the hiss go away.
     

Share This Page