1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

Horrible screeching sound from my memory toy

Discussion in 'Effects [BG]' started by b-bottom, Aug 14, 2012.


  1. b-bottom

    b-bottom

    Dec 18, 2006
    Knoxville TN
    Ok so I added a memory toy to my board about a month or so back. When I bought the thing it worked great. Now suddenly whenever I turn it on, it makes a horrific screeching sound.

    Now the pedal has done this at all of my practices except for when I first bought it, and my second to last one. The only thing that I think was different at those two practices was that I was the only one playing at the time. Again I don't know if that has anything to do with it or not.

    So any ideas on what the problem could be?
     
  2. Dark Barn

    Dark Barn

    Aug 3, 2010
    Seattle
    Sorry no help but the title is delicious. So dystopian.
     
  3. Smallequestrian

    Smallequestrian Rock and/or Roll

    Jul 6, 2004
    Chicago, IL
    Beta Tester: Source Audio
    Is it on a power daisy chain? The Memory Boy and Toy I had both did that when linked off a one spot.

    Not to mention the first Memory Toy I bought that was DOA...
     
  4. EskimoBassist

    EskimoBassist

    Nov 2, 2007
    Leeds, UK
    Sounds like you need an isolated power supply.
     
  5. TomA1234

    TomA1234

    Jul 27, 2009
    Fareham, England
    Try tightening all of the nuts on it.

    The same thing happened to my Boss chorus and that was due to a bad ground caused by loose nuts.
     
  6. b-bottom

    b-bottom

    Dec 18, 2006
    Knoxville TN
    I am running it off of a one spot. I'll try an isolated power source at my next practice.

    I'll also try tightening anything loose on it up.


    If it is the power supply, why would it do that?
     

Share This Page