1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Hum & radio interterence on Ampeg BA115

Discussion in 'Amps and Cabs [BG]' started by some1, May 20, 2011.


  1. some1

    some1

    Apr 27, 2011
    Hey guys, I've recently purchased an Ampeg BA115 online. When I plug my guitar into the amp, I get some radio interference. I've never had this before, so I'm confused. I had another bass & amp combo in the same room, location, etc. before and never had that problem. Is this something expected? Can I do anything to prevent it?

    Also, there is some amount of hum coming from the amp. The ones I tried in guitar center didn't seem to have that much hum to me (or maybe it was less noticeable), is this a common thing in Ampeg amps? I used to have a 75W Fender Rumble, and it was much quieter.
     
  2. RickenBoogie

    RickenBoogie

    Jul 22, 2007
    Dallas, TX
    Grounding issue. Check all AC cords and outlets.
     
  3. fdeck

    fdeck Supporting Member Commercial User

    Mar 20, 2004
    Madison WI
    HPF Technology LLC
    In my amp fixing days, the most common cause of radio interference was a loose ground or dodgy solder joint at or near the input jack. Also, the input jack tends to be the part of the amp that takes the most abuse.

    Of course you shouldn't open up your amp unless you are qualified to do so.
     
  4. bobba66

    bobba66

    May 18, 2006
    Arlington, Texas
    Is it a hum or more of a hissing sound? The tweeter in mine has a nasty hiss 'till I unplugged it.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.