Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

Iamp800 + Berg HT210 = Silence

Discussion in 'Amps and Cabs [BG]' started by SleeperMan2000, Jun 4, 2004.


  1. SleeperMan2000

    SleeperMan2000

    Jul 31, 2002
    Cary NC
    I read the other post and searched but I'm not having the same problem. Please bear with me, I'm a little mechanically declined.

    I have an Iamp800 and a Berg HT210.

    There are two speakon outputs in the back. One says +1, one says -1.

    I was trying to just use one cable, but I'm wondering if I actually need to use two cables to get the cab working?

    How do you connect the cables (which outputs to which inputs, I can physically connect them)? It's a 4 ohm cab. I can physically connect the cables, but I got nothing but silence.

    Amp was getting signal, the green input light was lit, the tuner was registering, could even get noise out of the direct output into the PA. Just nothing from the cab. Which makes me think I'm wiring it wrong.

    Any suggestions would be greatly appreciated! The manual doesn't discuss how to wire the cabs as far as I can see.

    Thanks.
     
  2. SleeperMan2000

    SleeperMan2000

    Jul 31, 2002
    Cary NC
    Oh yeah, and the speaker switch on the front the Iamp800 was on.
     
  3. jobu3

    jobu3 Artist formerly known as Big Joe

    Feb 17, 2002
    Mountain Top, PA
    On the inside of one Speakon end, there are two or four posts. They will be marked 1+ and 1- (or 1+ and 1- & 2+ and 2- if it is a four post Neutrik).

    Take one speaker cable's two inner wires and run the stripped off ends into the end of one connector. Make sure to use the 1+ and 1- slots, also make sure to remember which color combination went into which slot. Repeat at the other end using the same wires into the same slots... White into 1+ and black into 1- at both ends of the cable. If you are running one cabinet, you only need one speaker cable with two speakons (one at each end of the single cable with its two inner wires)... :cool:
     
  4. inazone

    inazone

    Apr 20, 2003
    Colorado
    Just to let you know, the berg ht 210 is a 8ohm cab.
     
  5. Sleeperman 2000
    You only need ONE SPEAKER CABLE NOT 2 !!
    What you need to do is go to your local music store [and take the manual for the amp with you] and purchase a Speaker Cable that has one SPEAKON CONNECTOR on one end [cause the i 800 Amp ONLY has speakon type connectors on it] and a 1/4 phono or speakon plug on the other end [depending on what type of female connector is on your speaker cabinet.] That's all you'll need. And if the cabinet is rated at 8 Ohms you'll get 500 watts out of the amp and if the cabinet is rated at 4 Ohms you'll get 800 watts from the amp. You don't need 2 cables. The +1 & -1 you see on the back of the Amp is the polarity of BOTH speakon jacks.[ Each jack has a +1 & -1 ]
    I'm very surprised that EA did not supply you with a Speaker Cable with the i Amp 800.
    PS.....My peronnal taste is to use the a MONSTER SPEAKER CABLE [12 guage wire or heavier for the connection ] Good Luck and enjoy your i Amp !!
     
  6. SleeperMan2000

    SleeperMan2000

    Jul 31, 2002
    Cary NC
    Thanks everyone for your generous suggestions.

    There is something wrong with the amp. I brought the amp (along with my backup, of course), and the sound guy and everyone in the room who knew anything could not get it working. Will have to send it back to EA. Be careful when you buy used stuff.

    I never did try connecting with the two wires, it was just out of desperation that I suggested it. I really thought I was doing something fundamentally wrong.

    Got through the gig with my Ampeg BA-210SP.