Ibanez BTB electronics help

Discussion in 'Pickups & Electronics [BG]' started by Justin V, Aug 22, 2003.

  1. Justin V

    Justin V

    Dec 27, 2000
    Alameda, CA
    I'm not sure if this belongs here, so move it if I'm in the wrong place.

    I just got done moving into my dorm a couple of days ago. I'm using a Pocket Rockit headphone amp for practicing. I brought up two basses with me. The first one is my Ibanez BTB400. The other one is an Essex fretless jazz. Everything was working great until last night when my Ibanez started sounding very distorted and quiet in the clean mode of the amp. I tried the fretless to make sure it wasn't the headphone amp and it worked just fine. I just replaced the batteries in the Ibanez, so I know that's not the issue. I think it might be my connection. It may also be something to do with my mid knob(s), which up until 10 minutes ago had always been a bit loose. I'm at a complete loss as to what to do. Please help me.
  2. Have you checked the batteries? I know that my Yamaha BBG4S does something similar when it wants a new battery...
  3. CS Bass

    CS Bass

    Feb 18, 2003
    +1 for the batteries.
  4. Justin V

    Justin V

    Dec 27, 2000
    Alameda, CA
    I just put new ones in a couple of days ago, but I'll check.
  5. Justin V

    Justin V

    Dec 27, 2000
    Alameda, CA
    What do you know...it worked.

    Thanks guys. I was worried that my electronics were messed up. I still don't understand why the new batteries were acting so weird.
  6. Pernax


    Jul 20, 2003
    I'm guessing that when you replaced the batteries, the battery clip got a bit twisted so it didn't hold correctly. Just tighten the metal clamp that goes over the pole of the battey and you should be ok.

  7. Petebass


    Dec 22, 2002
    QLD Australia
    you didn't accidantally leave the lead plugged in overnight did you?