1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Ibanez Soundwave 35 combo amp probs

Discussion in 'Amps and Cabs [BG]' started by Mooch, Mar 18, 2009.


  1. Mooch

    Mooch

    Jan 1, 2009
    MN
    Hey guys I got me a little Ibanez Soundwave 35 Combo amp.
    So, I turn it on today and its got demons coming out of the speaker. Its got a low rumble through the sub and fuzz through the tweeter. I took the front screen off and pulled out the speaker and unplugged it and replugged it and same thing.

    I then noticed the main power plug had something below it which I found was a fuse, it had a spare in it and so I swapped them around even though the original looked fine and same thing.

    So in my head its the amp part of the combo not the speaker. I never play it over vol 5 and it has sat for about a week or so because I just jam around the house on my acoustic.

    Am I screwed here or is it something someone knows what I can do?

    Thanks for anyhelp you can give.

    Mooch
     
  2. Swin

    Swin

    May 25, 2008
    Toronto
    Ibanez Freakazoid
    If it's new best to just return it for warranty replace/repair, then it's not your problem to resolve!
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.