Dismiss Notice

Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

insight needed on eden cab

Discussion in 'Amps and Cabs [BG]' started by pil101, Apr 4, 2005.


  1. pil101

    pil101

    Jul 8, 2000
    hey guys, heres my problem,

    i have an eden 210 xst that i bought new. a couple of months of playing through it, one speaker started distorting really bad. i took it back to the music store from which i purchsed it, we wound up switching the speaker from another 210 xst that they had. a couple months later the other speaker (the one that was not switched) has just starting distorting really bad as the other one did. i loosened the screws to check to make sure nothing was hitting against the speaker, it was clear. the amp sounds REALLY bad when i play anything on the "e" string. the speaker sounds really distorted and flops around a lot. mind you, this just happened suddenly and i have made NO recent changes to my settings or equipment. also no output lights light up on my head to show that i am pushing the cab too far. another point is that my band does not play that ridiculously loud. my settings are all pretty much at 12:00.

    heres my setup:

    eden wt-400 (which i just had the factory clean/check/retube service)
    eden 1x15 xl (8 ohm)
    eden 210 xst (8 ohm)
    fender pbass (passive)
     
  2. buffordbass

    buffordbass

    Nov 11, 2004
    Dallas
    Endorsing Artist: Genz Benz Amps, Lakland Basses
    Sounds like it's time for a warranty replacement to me. There bhave been a couple of posts on the Eden site regarding problems with the 210XST speakers, they are looking into it.
     
  3. Joe Beets

    Joe Beets Guest

    Nov 21, 2004
    Whew, and I almost bought one of those things. :meh:
     
  4. thejohnkim

    thejohnkim

    Sep 30, 2003
    NYC
    definitely not normal. ive been putting similar amounts of power into my single 210xst, 350 watts from one side of my dpc, with the attenuators wide open for a year or so ver regularly and i've had zero issues with the cab. so i'm sure its some sort of factory defect in both drivers as weird as that sounds to me. you should call eden and tell them whats been happening
     
  5. Joe Beets

    Joe Beets Guest

    Nov 21, 2004
    I've been pumping 3000 watts into a 112XLT for about 2 years now and it hasn't blown up yet. ;)