Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

intermittent problem with Ampeg B2R - help

Discussion in 'Amps and Cabs [BG]' started by basstrader, Oct 3, 2003.


  1. Hey I got this ampeg on the cheap knowing that it has an intermittent problem. It occasionally won't work, according to the seller. So I've been using it every day for about 2 weeks and it's fine. The issue was no sound at all. He would play it for a few weeks and then move it and pow, no sound. He said shaking it got it going again. Sounds like it might be a relay thing to me, but I can't get it to not work. Any ideas on how to go about troubleshooting?

    Thx
     
  2. BillyB_from_LZ

    BillyB_from_LZ Supporting Member

    Sep 7, 2000
    Chicago
    Check to see that the switching portion of the effects return jack is making good contact.
     
  3. Ampegs do occasionally have bad solder joints, one quick and easy place to start is my opening up the amp and checking the solder joints. Also make sure the flat multi connector cable between the Pre-Amp and the power amp is properly seated at both ends.

    If you need schematics you can PM me and I can help ya out there.

    Scott
     
  4. Thanks, I'll check it out. I haven't really had time to open the hood yet.
     
  5. pbd

    pbd Commercial User

    Jul 17, 2003
    Metro Detroit
    owner Procables N Sound
    If the previous owner had it racked maybe it wasn't getting enough air circulation. Try placeing it where it may be prone to warm up a little. Electronics don't like it warm. Ask the previous owner if he had heat or condensation problems. Just some thoughts for helping it to fail:eek: that just does not sound right....:D
     
  6. Yeah, I know what you mean. That's why there so hard to find, they aren't there all the time. Hope to be getting to it this weekend.

    Have a good one.

    BT