1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Is my Phathead...DEAD? :(

Discussion in 'Effects [BG]' started by Insomnia_Junkie, Dec 15, 2006.


  1. The other day I went to stomp on it and there is no signal, the red light comes on and everything but nothing comes through? I'm pretty sure it's past the warrentee(sp?) but is there anything else I can do?
     
  2. tplyons

    tplyons

    Apr 6, 2003
    Madison, NJ
    Check your cables? Power source?

    Unfortunately, I consider such pedals "disposable" as there's so much jammed into the pedal, that finding and diagnosing the problem could take HOURS, and at even a very low $10/hr bench rate, it's cheaper to replace than repair the current pedal.

    All the components are surface mount, the jacks, switch, etc. are cheap and are mounted directly to the PCB. No easy replacement either.

    I'd personally try the simple things, twiddling with the knobs, power source, and jacks, cables, etc. and crossing your fingers.

    BTW, does sound pass when the pedal is disengaged?
     
  3. No, unfortunetly sound doesn't pass. The red light still comes on when activated but I was just hoping it was permenatly dead :( it was like part of the family well... a part of the family that can easily be replaced...I guess
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.