1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

Is this sound supposed to be there?

Discussion in 'Amps and Cabs [BG]' started by Mugle, Jan 4, 2012.


  1. Mugle

    Mugle

    Jan 4, 2012
    Hi

    A few days ago i noticed a buzzing noise in my Ampeg BA-110. It comes when i pluck the strings and sits sort of in the background of the note.
    I didn't notice it in the store so i got concerned that maybe either the electronics in my bass or amp is starting to fail.

    is this normal with these amps or should i be worried? any way to prevent it?

    I play a G&L L2000 tribute if it matters
     
  2. PDGood

    PDGood Supporting Member

    Sep 19, 2010
    Nashville, TN
    A good way to test this is to isolate the problem. Try your rig with a different bass. If it still happens, it isn't the bass.

    P.S. Does this happen at low volume too or just high volume?
     
  3. RickenBoogie

    RickenBoogie

    Jul 22, 2007
    Dallas, TX
    +1 are we talking about alot of low end eq and pushing the volume up? If so, yes, it's normal. It's the speaker telling you to back off. If not, that's another thing.
     
  4. Mugle

    Mugle

    Jan 4, 2012
    Thanks for all the help but it seems that this is a sound that these amps are supposed to make. I guess i just have to live with it or upgrade.

    its not really that bothering either its just hard to unnotice when you have noticed it :)

    Thanks again everyone

    Mugle
     

Share This Page