1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Issue with GK MB Fusion

Discussion in 'Amps and Cabs [BG]' started by JeromeFrance, Apr 9, 2017.


  1. JeromeFrance

    JeromeFrance

    Apr 9, 2017
    Hi there,

    1st message here to report a problem with a GK MB Fusion 800...
    I am a French guy using German basses with US heads and French artisan cabs: perfect international combination!

    Today, I got these from my beloved GK Head.
    I checked all the parameters (cables, bass battery...) before posting.
    Sounds like it is a tube issue... Bought it in July 2016.
     

    Attached Files:

  2. murphy

    murphy

    May 5, 2004
    Toronto, Canada
    Do you mean the loud buzzing
    or the gurgly sound undereneath

    Yes...try a different tube first
     
  3. JeromeFrance

    JeromeFrance

    Apr 9, 2017
    Yes, all that.
    We can also hear when I switch from normal/-10db, Mute and Channel A/B.
     
  4. murphy

    murphy

    May 5, 2004
    Toronto, Canada
    easiest fix is tube replacement...so let us know if that fixes the problem
     
  5. Good luck changing the tubes in that thing.
    If you have trouble with the screws, I'd recommend a JIS screwdriver tip.

    There is at least one thread on TB about how to get to the tubes.
    You'll also need a 5.5mm nut driver or long socket.
     
    JeromeFrance likes this.
  6. JeromeFrance

    JeromeFrance

    Apr 9, 2017
    Thanks, I will let you know.
     
    Killed_by_Death likes this.
  7. JeromeFrance

    JeromeFrance

    Apr 9, 2017
    The head came back from tech last thursday.
    It was just an internal component that got loose with vibrations.
    Easy fix.
     
    Killed_by_Death likes this.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.