Dismiss Notice

Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

...It just went "POW!"

Discussion in 'Basses [BG]' started by 76Tbird, Mar 29, 2003.


  1. 76Tbird

    76Tbird

    Mar 18, 2003
    First gig with my new Warwick, I unplug the Tbird and get ready to switch to the 'wick, I put it on, plug it in and the amp went POW really loud and the bass would not work at all. I have no idea what happened, the amp is okay and I was able to use the ol' Gibson the rest of the night. So my question is... does anyone know what may have happened to my Warwick? there are several theories, from a bad connection at the jack to my onboard preamp taking a massive static shock and blowing out..it will be repaired, just need a place to start looking for trouble. thanks. :bawl:
     
  2. Ben Mishler

    Ben Mishler

    Jan 22, 2003
    San Jose
    It sounds like it is problem with your preamp, but it could be something else. Getting it repaired is a good idea, as it made need to be taken apart (the control cavity at least) to figure out the problem.
     
  3. Fliptrique

    Fliptrique

    Jul 22, 2002
    Szczecin, Poland
    Endorsing Artist: Mayones Guitars&Basses, Taurus Amplification
    does it have mec pickups/electronics? :(
     
  4. 76Tbird

    76Tbird

    Mar 18, 2003
    Sure does. Im guessing thats bad?
     
  5. Fliptrique

    Fliptrique

    Jul 22, 2002
    Szczecin, Poland
    Endorsing Artist: Mayones Guitars&Basses, Taurus Amplification
    do a search here on "mec". you`ll find that half of the results is about pickups or preamp commiting suicide durning a gig.

    i have mec.
     
  6. Does the bass have active electronics? You should never plug in an active bass without first turning the amp off or unpluging the cable at the amp. When the plug is inserted into an active bass, the battery voltage is momentarily connected directly to the two conductors of the cable. The resulting POP could damage your speakers.

    I don't know why the bass wouldn't work after that, though. Good luck finding the problem.
     
  7. 76Tbird

    76Tbird

    Mar 18, 2003
    thanks Im sure Ill need it:(