K & K mic question

Discussion in 'Amps, Mics & Pickups [DB]' started by Marc Piane, Jan 30, 2005.

  1. Marc Piane

    Marc Piane

    Jun 14, 2004
    I seem to be getting a bit of fuzz when I really dig in. I use the upgrade with a Realist. Has anyone else had this problem and what can I do about it?

    I recently took the mic off and am just using my Realist and am not missing the mic at all. Any thoughts on this too. I know there are a few people out there who use this combination successfully.

  2. Jazzman


    Nov 26, 2002
    Raleigh, NC
    It sounds like you are saturating the blender's mic channel. Try either slightly turning down the input gain, and/or pull the mic a little farther back away from the bass.
  3. PB+J


    Mar 9, 2000
    arlington va
    I just got a fishman full circle for exactly that reason--well that and the fact that I just always found the K+K finicky. When it was good it was very good, but I spent a lot of time at gigs fussing with it, and I also found I had to have the gain WAY up to get a decent signal.
  4. Marc Piane

    Marc Piane

    Jun 14, 2004
    Well, backing off the input gain seems to have helped.

    I'm wondering if anyone has tried the mic with an Underwood. I like the Realist by itself. The addition of the mic doesn't seem to do much. I think the tones are too similar. The Underwood has a very unique sound that is very different from a mic.

    Mostly I wonder this because I already own these pickups/mics. I don't want to buy anything new.