1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Lakland pre-amp. Help!

Discussion in 'Pickups & Electronics [BG]' started by Doctor J, Jan 3, 2007.


  1. Doctor J

    Doctor J

    Dec 23, 2005
    Just recieved a 55-02 with the Lakland pre-amp. It's not working in active mode. Not a whisper. It's fine in passive. I popped open the cavity to have a look and the black wire on the left hand side of the board, in terminal J1, isn't connected to anything. Can anybody help out here, any wiring diagrams to hand? Cheers.
     
  2. luknfur

    luknfur

    Jan 14, 2004
    DIXIE
    FWIW:

    just received from who? Whoever it is should be your first contact.

    Typically black is ground and if the pre's not grounded there's no complete circuit through it. If a Lakland dealer shipped it they'll probably just tell you to ground it. A look into the cavity with magnifying glass will likely indicate exactly where it was attached. Lakland may have an online diagram for it otherwise.

    If an individual shipped it then it's possible it could be a set-up as justification to back out of deal if you jack with it without their approval. If they won't send an email (phone calls are worthless) to that effect your choice is to ship it back as is or take your chances on the fix with nothing else being of consequence.
     
  3. Doctor J

    Doctor J

    Dec 23, 2005
    It's second hand, ebay purchase, seller is in a different country so shipping back would be a pain in the...

    I've been on to Lakland and they're helping me sort it out.

    Cheers.
     
  4. TrooperFarva

    TrooperFarva

    Nov 25, 2004
    New City, NY
    I gotta ask the stupid question that needs to be asked. Does it have a battery, and is it good?
     
  5. Doctor J

    Doctor J

    Dec 23, 2005
    I understand, I work in IT and have to ask the most ridiculous questions all day long ;) . Yes, the battery was the first thing checked, it is good and I replaced it with a brand new one just to be sure.

    I grounded that wire, still not working in active mode. I'm trying to get a schematic from Lakland.
     
  6. basspraiser

    basspraiser Jammin for the Lamb! Supporting Member

    Dec 8, 2006
    Chicago - NW Burbs
    e-mail Dan Lakin directly (e-mail address on the lakland site) - he will get you an answer.......
     
  7. Doctor J

    Doctor J

    Dec 23, 2005
    Indeed. As I said I've contacted Lakland and Kirk is very kindly helping me out.

    Thumbs up for Lakland customer service.

    Thumbs up for their bass too, even in passive mode, I can appreciate why they are held in such high regard by so many TBers. Thanks guys.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.